
Tutorial on using QChromosome Visual-
izer (QCV) software for chromatin model 
simulations 
In this tutorial you will learn the main functions of QChromosome Visualizer (QCV), starting from 
loading a molecule, through modifying the parameters of the visualisation of the molecule and 
ending up with rendering high-quality molecule images and movies. 
In this tutorial we use as an example the trajectory of a model of first part (1000 pseudoatoms) 
of the chromosome arm 2L of Drosophila melanogaster that was generated by our implementa-
tion of the Strings and Binders Switch (SBS) model. The 2chr_PolII.pdb.gz file with Drosophila 
chromatin MC trajectory is provided on our web server with the tutorial at the following URL: 
http://regulomics.mimuw.edu.pl/~bartek/QCV/chr2_polII.pdb.gz. The file is using a standard 
PDB format with each frame bracketed by MODEL and ENDMDL records. The single chromo-
some segment consists of four types of pseudoatoms, representing 20 kbp of DNA each. 
Pseudoatoms with the ability to interact with Polymerase II are named BOU (as in bound), 
pseudoatoms that interact with lamin (chromatin sites that bind suppressor of hairy wing 
Su(Hw)) are named LAM, other chromatin pseudoatoms are named UNB. Polimerase II is rep-
resented by freely diffusing pseudoatoms that are named BIN (as in binder). The simulation was 
obtained using our implementation of the SBS model described by Barbieri et all. 2012. 

In this tutorial, we will go through the main functions of the QCV software, opening a project, 
importing a pdb file, viewing the simulation, changing the view parameters, saving high quality 
snapshots and animations, including 360 videos and saving the project files. 

Starting the application 

After installation procedure, described in the readme file of the source code distributed on github 
at https://github.com/regulomics/ChromosomeVisualizer, in order to run QCV just write in the 
terminal: 

!  

Once we have started the application, the main window appears with an empty project allowing 
us to load the data and start setting the parameters of the visualisation 

Loading the trajectory 
To load the new trajectory to the program just choose File → Import and find the pdb file you 
want to open.  

http://regulomics.mimuw.edu.pl/~bartek/QCV/chr2_polII.pdb.gz
https://github.com/regulomics/ChromosomeVisualizer


!  

Another window named Import - [2chr_polII.pdb.gz] will appear and let choose the range of 
the frames to load (First and Last) and a number of frames skipped (Stride) between the 
loaded steps (this is useful if we are loading from large files with many small steps recorded). 
Changing the Stride value to 5  means that every fifth frame from the trajectory will be loaded 
into the QCV program. If you want to load all chosen trajectory steps at once immediately, select 
Load all at once option. This is however, impractical for large files, as it takes up more memory 
than it is necessary. In order to avoid that and have more control over the loading process (e.g 
one can stop the loading and restore it again), we recommend to select Load in background 
option and press Ok. This will make the program only read frames to memory as they need to 
be shown. 

!  

First step of chr2 trajectory is showed in the main QCV window. You can manipulate (rotate, 
translate, scale) the molecule by using an appropriate bottoms on the Menu tool. 

!  



Load next steps of simulation and stop loading any time you want by pressing Play/Stop button. 

!  

During the loading process two line appears in the Animation toolbar. Upper one shows the 
number of loaded steps, as well as marks of the state that is displayed in the main window. 
Lower one allows to play/render only an appropriate range of the trajectory. 

!  

Loading the data that describe the simulation 
Using QCV you can easily make charts for data that describe the progress of the simulation, like 
energy, radius of gyration, temperature etc. All data can be given in one text file in xvg format, 
where first column will be ignored by the QCV program while second and next columns are in-
terpreted as Y values for different sessions. In the first lines, you can put the name of each ses-
sion after the @ sign in the format @ sNR legend “NAME OF THE SESSION”, like on the pic-
ture below.  



!  

In our case the first column describes the frame number in our trajectory, second column is a 
score or “energy” while third is a radius of gyration. 

To load data for making charts just choose File → Import and find the xvg file (in our case 
chr2_polII.xvg) corresponding to the loaded trajectory. Press Open button. 

!  

The legend appears in the Chart of data analysis window and the indicator of the currently 
displayed frame has returned to the beginning of the trajectory. The name of the loaded file ap-
pears in the Objects window. Press Play button to load data from the xvg file. 

http://regulomics.mimuw.edu.pl/~irina/QCHromosome/chr2_polII.xvg


!  

It i s possible to go down in the object tree and see the title of all graphs that appeared in the 
Chart of data analysis window. 

As we can observe in our case there are big differences between energy values and radius of 
gyration values, therefore the red plot is almost invisible. To analyse radius of gyration changes 
we need to hide the plot that describe energy changes. In order to hide the plot double click on 
the grey upper dot opposite the Energy name in the Objects window.  

!  



The blue plot disappear, while the values described in the Chart for data analysis window are 
recalculated for the red plot. 

!  

As you can see, the indicator of the structure that is displayed in the main window is not only on 
the line that describe loaded frames of trajectory, but also on the plot, what is very convenient 
for example to analyse changing of the structure in the place of a sudden drop/rise in energy/
radius of gyration/temperature etc. 

Changing the visualisation of the molecule 
In the QCV program each object has a tree structure. In the Object window click on the arrow 
near the molecule to go down in the object tree. The arrow becomes white instead of grey and 
daughter objects appear.  
Go down until atoms names (UNB, BOU, LAM, BIN) appear and click on the BIN atom name. It 
will be highlighted both in the Object window as well as in the main program window. 

!  

There is two ways to hide atoms in the QCV. First is to double click on the grey dots opposite 
the BIN name in the Objects window. The upper dot is responsible for hiding/visualising on the 
screen, while the lower one - for hiding/visualising during the rendering a picture. If atoms are 
hidden, the dot is marked red (see red square on the Figure below). Second - to chose off for 
the Visible in editor or/and Visible in renderer options in the Attributes window. Choose the 
most convenient way for you and hide BIN atoms. 



!  

In order to change the atom colour and material click on the ball that represent atom in the Ob-
ject window. The ball will be highlighted. 

!  

Simultaneously in the Attributes window appear attributes connected with atom representation. 
Click on the colour opposite Color option and choose any colour you want from the Colors win-
dow. I chose white. Click Ok button. 

!  

The representation of the atoms will change in all available windows. 



!  

In the Attributes window choose Color tab and change Transparency parameter to 10% and 
Finish option to Glass (red squares). Representation of atoms will change. 

!  

Repeat the same steps for all atom types. I leave red colour for BOU atoms and change LAM 
atom color to Blueberry (the colors dialog shown is different on different platforms, the one 
shown is from Mac OS X). 



 !  

 !  

In our trajectory UNB atoms do not play an important role in the chromatin structure, therefore 
we will reduce their size. In order to change the size of UNB atoms click on the atom name UNB 
in the Object window and UNB name in the Objects window will be highlighted as well as ap-
propriate atoms in the main window. In the Attributes window appear attributes of atoms. 

!  



Click on the Object tab of the Attributes window and change Sphere radius to 0,5 values. It 
should be emphasized that Sphere radius value can not be lower than Cylinder radius. 

!  

In order to change the background color choose View → Options → Configure, in the Attribut-
es window, click on the Back tab and change the Background color to white or your favorite 
one. Due to the fog effect is on and the color of fog is black, the background is not white, but 
rather light grey. However we do not recommend to turn the fog off. 

!  

!  

In order to turn off highlighting of atoms in the main window, click on the Rectangle selection 
icon on the Main toolbar or choose Select → Rectangle selection, and next click on the back-
ground of the main window. 



!  

Save high quality pictures 
Click on the Play button and load the rest of trajectory, next find your favorite frame. Manipulate 
of molecule by using Move, Rotate or Scale buttons on the Main toolbar, or in the Menu 
Tools, to see it from the most interesting perspective.  

!  

QCV program rotates the molecule around its center of mass. If you want to change the rotation 
center, select the group of atoms or one particular atom and click on the Pivot point button on 
the Main toolbar. 



!  

To set appropriate options of rendering, click on the Render setting bottom in the Main toolbar 
or choose Render → Render setting. 

!  

Choose Output tab in the opened Render Settings window and make sure that Lock ratio is 
selected. If not, select it. Change Width value to 2000 and press Enter. The Height value will 
change automatically.  



!  

Choose File tab in the Render Settings window and write the file name in the File option. 

!  

Close Render Settings window and click on the Render button in the Main toolbar or choose 
Render → Render to Picture Viewer and the process bar will appear on the bottom of the pro-
gram windows.  

!  

When the process of rendering the image is finished, the figure will appear in the selected fold-



er. Below is the picture we obtained after finishing the render process. You can find it in the Tu-
torial folder called chr2_polII_figure.png. 

!  
Movie Making 
If you do not want to record all trajectory, choose any part of loaded frames by moving the end 
points of the blue slider in the Animation Toolbar. I chose first fifty frames. In the same time the 
range of loaded frames is limited to the one set by you by moving the blue slider. 

!  

Now, when you press the Play button, the animation will continue to play outside the range of 
selected frames. To limit the playback of the animation to the selected by the user by moving the 
blue slider, choose Animate → Play mode → Preview range. 

http://regulomics.mimuw.edu.pl/~irina/QCHromosome/
http://regulomics.mimuw.edu.pl/~irina/QCHromosome/
http://regulomics.mimuw.edu.pl/~irina/QCHromosome/chr2_polII_figure.png


!  

Now click on the Play button and change the position of the molecule (rotate, translate, scale) 
so that it is clearly visible on the monitor during the entire playback process. 
In order to add addition movement to the animation (rotations, translations, or scale) we need to 
add keyframes. Click on the forth frame of animation and rotate slightly molecule. Next press 
Record position button on the Animiation Toolbar. The mark of the saving keyframe will ap-
pear. Each keyframe can be deleted by selecting the keyframe mark and next pressing Del but-
ton on the keyboard.  
During the rotation of the molecule using mouse or touchpad, the program moves the camera 
around the molecule. While during the play/render the simulation with keyframes, where mol-
ecule was rotated, the program interpolates the path between the nearest keyframes. Please 
remember that if the rotation is interpolated over large angles (i.e. two consecutive keyframes 
showing the chromosome from the opposite sides), the movement between  keyframes during 
the animation may become difficult to predict (e.g. there can be moments when camera is not 
facing the molecule or there might be sudden changes of perspective).  In order to avoid this, 
rotation movement between keyframes should not to cover large angles. This can be achieved 
by adding additional keyframes to give more point to the interpolating process. If during play-
back of the simulation the movement of the molecule between two frames with rotation is unex-
pected, simply go to the affected frame, scale/move the molecule to the place you want it to be 
and add a new keyframe.  

!  



Now open render settings, by clicking on the Edit render settings button in the Main toolbar.  

!  

The Render settings window will open. Choose Output tab and check if the resolution is ap-
propriate. We have already changed it, when rendering the picture. It should be at least as high 
as your screen resolution (usually 1920x1090 for high definition displays), however if you want 
to obtain really good movies, we recommend generation of higher resolution images e.g. in 4K 
resolution, as  higher resolution movies downsampled to the native resolution tend to look bet-
ter. 

Change the Frame range options to Preview range, so your movie will have only those frames, 
you have chosen by moving the blue slider in the main window. 

!  



Now choose File tab and change the filename in the File gap. Next close Render settings win-
dow. 

!  
  
Now click on the Render button in the Main toolbar or choose Render → Render to Picture 
Viewer and the process bar will appear on the bottom of the program windows.  

!  



When rendering process is finished open the movie and playback the simulation. My movie file 
is called chr2_movie.avi and it is available in the Tutorial folder. 

If your simulation frames are far apart (many pseudoatoms move at the same time) the move-
ment of molecule might be quite rapid and “jerky”. We can smooth the animation movement  by 
adding interpolated frames in between the simulation frames. For that, we need to open  the 
Render Settings window again. 

!  

Choose Output tab and change Frame rate parameter to a value higher than 1 (e.g. 5), that  
makes QCV  we will putt addition four virtual frames  between each pair of consecutive frames 
with positions of all pseudoatoms and the camera smoothly interpolated in beetween. That 
should  smooth the movement between the actual simulation frames. Naturally, we should re-
member that while this greatly improves the visual appearance, it should not be misinterpreted 
as the direct representation of the simulation states. 

!  

Change the file name in the FIle tab of the Render Settings window and close Render Set-
tings window. Click on the Render button in the Main toolbar or choose Render → Render to 
Picture Viewer and the process bar will appear on the bottom of the program windows. You can 

http://regulomics.mimuw.edu.pl/~irina/QCHromosome/chr2_movie.avi
http://regulomics.mimuw.edu.pl/~irina/QCHromosome/


notice that now there is five time more frames than before. 

!  

After finishing the render process, you could compare movies. My movie with additional virtual 
frames is called chr2_movie_smooth.avi and you could find it in the Tutorial folder. You can 
change Frame rate parameter in the Render Settings window to smooth the animation and 
FPS (Frames Per Second) parameter to slowing down/speeding up the simulation. 

!  

Generating 360 stereoscopic video 
Since the advent of the new technologies for immersive visualization, commonly called VR, 
there are multiple technologies allowing visualisations including the full sphere of vision and al-
lowing the viewer to “look around” in the scene as the animation/movie progresses. Since chro-

http://regulomics.mimuw.edu.pl/~irina/QCHromosome/chr2_movie_smooth.avi
http://regulomics.mimuw.edu.pl/~irina/QCHromosome/


mosomes are very complex 3d objects, we think that using these new tools should allow us to 
better understand the processes occuring in our simulations.  

QCV allows us to generate such spherical (360) movies that are compatible with the popular 
youtube platform. When the user decides to generate such a visualization, it can be uploaded to 
youtube and viewed either on a regular computer (allowing to move the viewport by dragging 
with the mouse) or on a VR headset such as Google VR, Google cardboard or any other plat-
form supporting google 360 videos.  

In order to record 360 videos, you need to create a new camera object, by selecting the Add 
camera object option from the Main toolbar. Then you can see a new camera appears in the 
objects browser on the right panel and you can activate it by clicking the icon beside it. If you 
activate it, you will see that this camera has its own set of attributes in the Attributes window, 
and you can change many of its features, such as the viewing angle. However the most impor-
tant option for us is now in the Stereoscopic attributes tab on the far right. If you switch the 
mode of the camera to the Symmetrical options as it is shown in the figure below, you will gen-
erate the video for two-eye 360 videos. You can also choose to generate video sequences for 
the left and right eye separately, if you want to use other techniques for visualization.  

Please note, that you can have more than one camera object, and that the keyframes for each 
camera object can be different, so please remember to make sure that you have activated the 
right camera object and that it has all the necessary keyframes set before rendering. 

 

Once you have everything set up, you can click on the  Render button in the Main toolbar and 
after a little while, you should see your 360 movie playing in a system video player. The movie 



will look strange in the standard video player, as the images for both eyes are placed above one 
another and the perspective is highly distorted because of the cylindrical projection as in the 
screenshot below: 
 

My movie file is called movie1.avi and it is available in the Tutorial folder. 
Now that you have generated the .avi file and verified that it is viewable on your system (even 
though it does look different) you can prepare it for upload to youtube. Currently it involves two 
steps: preparation of the file and upload.  
In order for youtube software to recognize the movie as a 360 spherical video, we need to use 
their metadata editor, distributed freely through their github account: https://github.com/google/
spatial-media/releases/tag/v2.1 
There are versions available for windows and Mac and the source code version can be run on 
linux systems. 
Since their application only works on Mpe4 files, we need to start by converting our movie to the 
mpeg format by issuing the ffmpeg command: 

ffmpeg -i movie1.avi -acodec libmp3lame movie1.mov 

Assuming that we have named our output file movie1.avi, we should obtain a new file called 
movie2.mov in this way. Now we are ready to inject the metadata by starting the GUI version of 
the spatial media tool from google. We should see a dialog box like the following: 

http://regulomics.mimuw.edu.pl/~irina/QCHromosome/movie1.avi
http://regulomics.mimuw.edu.pl/~irina/QCHromosome/
https://github.com/google/spatial-media/releases/tag/v2.1
https://github.com/google/spatial-media/releases/tag/v2.1


Once we click on the Open button it will allow us to select our mpeg4 encoded video: 

!  

After selecting the video, we should be able to select both options for the  stereoscopic 360 
video and click on the Inject metadata button creating  a new file (in this case movie1_inject-
ed.mov).  

!  
After this process is done, we can head to the upload screen on youtube and upload the video. 
After uploading the video will be viewable in the 360 mode. It should be noted that it may take a 
few moments before the movie is fully processed by youtube, and during that time the video 
may not be properly recognized as spherical, as shown in the screenshot below: 

 
Once the processing is over, the video will be visible in the 360 version of youtube browser al-
lowing for tilting the view and other “3D” options as shown below: 

http://regulomics.mimuw.edu.pl/~irina/QCHromosome/movie1_injected.mov
http://regulomics.mimuw.edu.pl/~irina/QCHromosome/movie1_injected.mov


!  

The same video viewed in the VR capable browser, such as a cellphone with a gyro sensor or a 
VR headset will be automatically presented in the stereoscopic view. 



Saving the project 
QCV program allows you to save and later open all settings and changes applied by you. In or-
der to save session, choose  File → Save as…, next choose appropriate path and filename and 
enter OK. My project is called chr2_polII.qcs and is available in the Tutorial folder. You should 
remember that if you download my chr2_polII.qcs file, you should change paths to chr2_polI-
I.pdb.gz, chr2_movie.png and chr2_polII.xvg files.  

!  

In order to open saved session choose File → Open, choose file with QCV session and enter 
OK. 

!

http://regulomics.mimuw.edu.pl/~irina/QCHromosome/chr2_polII.qcs
http://regulomics.mimuw.edu.pl/~irina/QCHromosome/

